Before installing VTGram, please make sure following PHP requirements and extensions are installed and enabled on your server:

PHP versionPHP version 5.6 ~ 7.1
allow_url_fopenallow_url_fopen=On (php.ini file)
PHP cURLRequired. (Curl Library, Curl_init Function and Curl_exec)
PHP OpenSSLRequired. (For secure data encryption.)
PHP PDORequired. (To create secure connection to MySQL server)
GDRequired. (For image processing).
PHP EXIFRequired. (For validating JPEG files)
PHP mbstringRequired.
CronjobsRequired (The cronjobs must be configured for publising scheduled posts.)
FFMPEGRequired for video posts. (For Video post types.)
ZipPHP zip extension is required (for updating, installing etc)
Option (Recommended)To upload large videos and some thing like that, you need to increase the following values in your server
memory_limit = 256M 
upload_max_size = 64M 
post_max_size = 64M 
upload_max_filesize = 64M
max_execution_time = 60
max_input_time = 500
max_connections = 200
max_user_connections = 200
wait_timeout = 180
max_allowed_packet = 512M